I llegle version is detected in use